The Nexus menu bar contains the following controls:

File menu

The File menu contains the following options:

Edit menu

The Edit menu contains the following options, which take effect only when the system is in Pause or Offline mode:

Window menu

The Window menu contains the following options:

Quick reports

The Nexus Quick Reports window enables you to display multiple graphs of model outputs normalized over the gait cycle (like a simplified Vicon Polygon graph view).

To display model outputs in Nexus Quick Reports:

  1. On the Window menu, click Quick Reports, or press F4 to open the Nexus Quick Reports window.
  2. In the main Nexus window, ensure that the trial (*.C3D file) that you want add to Quick Reports is the current trial.
  3. From the Pipeline Tools pane, expand Data Processing and double-click Add Trial to Quick Report to add it to the current pipeline.
  4. In the Current Pipeline list, right-click the Add Trial to Quick Report operation and click Run select Op.
  5. For each trial that you want to add, repeat step 2–4.


    Tip
    To add trials to Quick Reports, you can also:
    • Drag and drop one or more trials (*.C3D files) from Windows Explorer into the Quick Reports window; or
    • Click the Add To Quick Report button on the Nexus toolbar (adds the current trial); or
    • On the Data Management tab, mark the required files and in the Quick Reports window, click Import Marked.
  6. In the Nexus Quick Reports window, the added trials are displayed in the Trials list, by default on the right of the window.
  7. From the Display Mode list, select the required option.



  8. Ensure the required cycle is selected in the Left and Right columns.


    Tip
    To change the options for all the trials, in the Trials section, click the appropriate option at the top of the columns.

  9. To display model outputs in the graphs, in the Model Outputs list, expand the relevant node and then select the required check box(es).

    The selected outputs are displayed as graphs in the Nexus Quick Reports window.

    To display only the required components, in the Model Outputs tree, clear the check boxes for the unwanted components.
    For example, if you are interested in AnkleMoment X only, you can select this only.


    Tip
    By default a red line represents data from the left side and a green line represents data from the right. The trial currently selected in the Report Options list is represented by a heavier line on the graphs. To change green and red to solid and dashed lines, in the Options dialog box (press F7), on the left, click Quick Reports and then clear Use Context Colors. To change the colors displayed for each trace on the graph, click the color(s) that you want to change.
  10. Expand the Gait Cycle Analysis section at the bottom left of the window and ensure the Distance Markers and Units are as required.



    Tip
    If the nodes are not expanded, the Parameter column displays average values (in bold) across all selected trials. To view the average value for each trial, ensure the relevant parameter nodes are expanded.

  11. To export a PDF of the data in the Nexus Quick Reports window:
    1. Expand the Export Options section and clear or select as required.
    2. From the Title Alignment list, select the required option.
    3. Click Export and in the Export to PDF dialog box, enter or browse to the required location.
    4. Click Save.
  12. To save your work, click the Save button at the bottom of the Report Options pane and select the appropriate option:

About the Nexus Quick Reports window

The Nexus Quick Reports window comprises two sections:

To the bottom left of the main workspace, Gait Cycle Analysis parameters for the loaded trials are displayed.

In the large text box on the right, you can enter a description or notes, etc, which can be formatted using the buttons on the toolbar above the text box.

To close the Nexus Quick Reports window, press F4.

Report Options controls

In the Report Options pane, the following controls are available:

ControlDescription
Subject fieldEnables you to select the subject whose data you want to view.
Trials listLists the trials that you have added to the report. In this list, you can select or clear the relevant check boxes to display the required trial(s). To show/hide all trials, expand the Trials section and select or clear the check box at the top. The outputs for selected trials are displayed in each graph.
The Cycle dropdown lists at the top and in the Left and Right columns of the Trials list enable you to select which gait cycles to show for the left and right contexts for each trial.
To select trials, click (or Shift+click/Ctrl+click) in the Trial column of the required row(s) in the list. The selected row(s) in the list are highlighted with a blue background and by thicker lines in the graph.
To remove selected trials from the report or to mark selected trials in Data Management (eg, for use in Vicon Polygon), click Remove Selected or Mark Selected at the bottom of the list.
Model Outputs listDisplays available model outputs from the trials that have been added to the report.
Export buttonOpens the Export to PDF dialog box, which enables you to save the contents of the current Nexus Quick Reports window to a *.PDF file, with a name and location that you specify.
Save buttonEnables you to save the current Quick Report either as a document (*.qrd) or a template (*.qrt).
Open button
Enables you to enter or browse to a Quick Report document (*.qrd) or a template (*.qrt).
Apply Report Template button
Enables you to apply a report template that was saved to the default location (C:\Users\Public\Documents\Vicon\Nexus2.x\Configurations\QuickReports).

Sounds dialog box

Nexus can play sounds through your PC's speakers to alert you when a Nexus event has taken place (for example, operation completion, system status, and issues). This keeps you informed of system status while you're still in the volume, so that you don't have to spend time returning to the PC to look at the screen.

You can access this dialog box from the Window menu or by pressing F6.

By default, Nexus uses speech sounds to alert you to the following events:

Nexus is supplied with a set of default sound files (.wavs). You can modify the sounds that are used for each event and you can disable sounds individually or disable all sounds.

To disable all sounds, in the Sounds section, clear the Enabled check box.

To disable one or more sounds, click the relevant drop-down arrow and select (None) from the list.

To choose one of the other sounds supplied with Nexus, click the drop-down arrow and select the required sound from the list.

To substitute your own sounds for those supplied with Nexus, click the relevant ellipsis (...) and enter or browse to the location of the required .wav files. 

Use the configuration management area at the top of the Sounds dialog box to name, to save, delete and if necessary protect the sounds that you have allocated to Nexus events. After you have saved sounds configuration files, you can select them from the menu at the top of the dialog box and can use the Configuration menu to manage them.

The sounds configuration file (*.AudioScheme) is saved into an AudioSchemes folder, in the same location as other Nexus configuration files (see Managing configurations in Vicon Nexus in the Vicon Nexus User Guide).

Options dialog box

The Options dialog box enables you to control the way data is visualized in the view panes . You can access this dialog box from the Window menu or by pressing F7.

The Options dialog box includes a configuration area:

This enables you to save any changes you make in the Options dialog box to a configuration file, with the extension .Options. You can then re-use your saved configuration file as required, for example, you could save a different set of options for each type of motion capture application that you use.

In addition to creating customized Options configurations, the Configuration menu button enables you to rename, import, reload and delete configurations, and refresh the list.

To configure settings in the Options dialog box:

  1. Open the Options dialog box in either of these ways:
  2. In the list of options on the left side of the dialog box, click an option whose properties you wish to view or change. You can now:
  3. Repeat step 2 for each property whose settings you wish to configure.
  4. To save your settings, do one of the following:

Vicon Control dialog box

To open the Vicon Control dialog box, on the Window menu, select Manage Control Authorizations.

The Vicon Control dialog box enables you to carry out the following operations:

Error Settings dialog box

The Error Settings dialog box enables you to adjust the length of time that popup notifications are displayed and their maximum number.

To control popup notifications:

  1. On the Window menu, select Error Message Settings.
  2. In the Error Settings dialog box:
    1. Change Popup timeout to the length of time (in seconds) that you want the messages to be displayed, up to a maximum time of 10 seconds.
      Note that if you set Popup timeout to 0, the error message remains unless you either click on the message or the Max Errors to Show is reached, when this error message is automatically removed.
    2. Change Max Errors to Show to the number of error messages that you want to be displayed at any one time, up to a maximum of 10 messages.

      The default popup timeout is 5 seconds and the default number of messages is 5.
      If more errors occur within the Popup timeout period, the oldest error is removed from the top of the stack and newest is displayed at the bottom of the stack.

To open the Log, click on any of the error messages.

Help menu

The Help menu contains the following commands: