Vicon Shogun banner

About Shogun 1.3

Shogun 1.3 is the third point release of Vicon’s entertainment market software.

It includes new features such as the first phase of Vicon's new high fidelity finger solver and retargeting feature, as well as a number of bug fixes.

For a more detailed description, see New features in Vicon Shogun 1.3 or watch the Vicon Shogun videos:

On YouTube:
What's new in Shogun Live 1.3? and What's new in Shogun Post 1.3?

On Vimeo:
What's new in Shogun Live 1.3? and What's new in Shogun Post 1.3?

This release also benefits from ongoing maintenance, with a large number of issues having been addressed (see Addressed issues in Vicon Shogun 1.3).

For information on requirements for installing and running Shogun, see PC requirements in Installing and licensing Vicon Shogun, visit the FAQ, 'What is the recommended computer specification to run my Vicon Shogun system' on the Vicon website, or contact Vicon Support.


New features in Vicon Shogun 1.3

For descriptions of the new features in this release of Shogun, see the following topics:

Shogun Live 1.3

For descriptions of the major new features in this release of Shogun Live, see the following topics:

High fidelity finger solver

Shogun 1.3 features a new, high-resolution finger-solver, which supports a full finger model that is capable of capturing high fidelity motion, including palm motion.

Not only are fingers now calibrated based on the performers' real hands, but the labeling process also uses the new feature, so that the data is cleaner and more accurate.

In addition, the new retargeting feature also makes use of the improved finger animation, enabling you to see realistic finger motion on your own game characters as they interact with props in real time.

For more information on using the new high fidelity finger marker sets in Shogun, see Create subjects in Getting started with Vicon Shogun.

Note for users of finger markers in Shogun 1.2

If you used marker sets that included fingers in previous versions of Shogun, note the following points:

  • The 6Z marker set is no longer included.
  • For the current (Shogun 1.3) 3 finger-marker set, the marker names are identical to the former 5-from-3 model (LTHM3, LIDX3, LPNK3, etc.).
    This ensures that you do not need to re-label sequences that were previously captured and labeled with Shogun 1.2.1.
  • If you re-label old (pre-Shogun 1.3) ROMs from scratch using the new skeletons, T-pose booting may not work as expected, due to the change to A-pose booting (see A-pose for subject calibration).

New marker cluster workflow

If you're using a labeling cluster for a subject who is wearing a marker set that includes high fidelity fingers, before you calibrate the subject, select the required labeling cluster from the Labeling Cluster To Use list on the Subject Calibration tab.

For more information on using labeling clusters, see Create and calibrate a subject, in Getting Started with Vicon Shogun.

New retargeting feature

You can now retarget from the Vicon Shogun character onto any custom biped skeleton in FBX format, enabling you to see your own characters being driven by the motion capture data rather than the standard Vicon one.

Working with Vicon Shogun retargeting in conjunction with the new Vicon game engine plugins for Unity and Unreal, you can see your character in the game engine within seconds.

For more information on retargeting with Shogun, see:

and the relevant videos on YouTube:

Vicon Shogun 1.3 Post Tutorial - Retargeting Setup

Vicon Shogun 1.3 Post Tutorial - Retargeting Test

Vicon Shogun 1.3 Post Tutorial - Streaming Retargets into Unreal

   

Multi-machine capability

Shogun Live's new multi-machine capability lets you boost processing performance, resulting in fewer dropped frames, by running a standalone agent on one or more other machines on the same network.

For setup information, see:

Run Shogun processing on multiple machines in Getting more from Vicon Shogun

and

 Vicon Shogun 1.3 Live Tutorial - Multi-machine Workflow on YouTube

A-pose for subject calibration

To enable performers to adopt a more natural pose for subject calibration, subjects are now calibrated in an A-pose, rather than a T-pose.

New Production marker set

Shogun 1.3 includes a new Production marker set and templates. The Production marker set helps to avoid marker occlusion and includes extra markers for the back and top of the shoulders to help with gap-filling and solving. Four variations are included:

  • Standard Production marker set
  • Production marker set plus 10 finger-markers
  • Production marker set plus 5 finger-markers
  • Production marker set plus 3 finger-markers

For more information, see Create subjects in Getting started with Vicon Shogun.

Ability to align props to world axis

You can now quickly align a selected prop to the world axis.

With the prop selected, display the Object Manipulator, ensure it is set to Global and change all the prop's values to zero.

For more information, see Move props in Getting started with Vicon Shogun, Create props.

Reconstruction volume and subject calibration hotspot

The new reconstruction volume feature lets you set aside a part of your volume specifically for subject calibration ROMs, leaving the rest of the volume free for scene setup/rehearsals, etc. You can now avoid having to clear the volume whenever you want to calibrate or re-calibrate a subject.

For details, see Create a subject calibration hotspot in Getting more from Vicon Shogun.

Custom L-frame and set origin workflow

In Shogun Live you can now use a custom L-frame to set the origin of your system.

You can use a Vicon Active Wand to set up your volume coordinate system quickly and easily. However, using a larger, custom calibration object (in this case, markers embedded in the volume floor and/or wall) can improve calibration stability and consistency over time.

For more information, see:

Set the origin with a custom L-frame in Getting started with Vicon Shogun, Calibrate cameras

and

 Vicon Shogun 1.3 Live Tutorial - Custom L-Frame Workflow on YouTube.

Rotating cameras

When cameras are physically rotated, Shogun Live adjusts to display the cameras with the correct rotation.

After system calibration, the camera 'tunes' itself to update its rotation based on calibration.

To set the rotation to snap to the nearest 90 degrees, in the Cameras view, display the View Filters  and in the 2D Data section, select the Snap to 90° check box.

New matrix display for view filters

To find out about the new View Filters options, see:

 Vicon Shogun 1.3 Live Tutorial - View Filter Matrix on YouTube.

The View Filters for the 3D Scene view have been enhanced and reorganized to make them easier to use.

The view options are displayed in a matrix, with columns for Labeling, Solving, Retargeting and Props, enabling you to choose a view configuration that suits your current task.

The default view filter sets are for solving, retargeting, and labeling, but you can add your own filter sets by clicking New Preset.

To rename, copy or remove any filter sets, right-click on a filter set and then click the required option.

Your settings, including any custom presets, are automatically saved, so that you can easily re-use them for different workflows.

Marker count on current selection

The new Marker Selection counter enables you to easily check the number of markers currently selected. This is useful if, for example during subject calibration, you need to check that the required number of markers have all been placed on a subject, or within a particular set of markers (for example, facial markers).

To display the number of selected markers:

  1. In the 3D Scene view, ensure View Filters is selected and in the Overlays section, select the Selected Marker Count option.



  2. As you select markers (in either the Subject pane (left) or the view pane), the Marker Selection counter at the bottom right  of the view pane changes to display the number of selected markers.

Camera mask painting

If you add equipment or markers into the volume after you’ve finished auto-masking, or if you have an issue with specific camera(s), it is time-consuming to have to repeat the masking process.

Instead of re-starting the whole auto-masking procedure, you can now keep your original masking and add to it using further auto-masking, and/or manually paint out any additional reflections.

For more information, see Mask cameras in Getting Started with Vicon Shogun.

Low disk space warning

Shogun Live now warns you if your capture drive(s) reaches a specified capacity.

To change the amount of free space remaining before Shogun Live alerts you:

  1. In the Settings dialog box (Settings > Preferences, or Shift+P), click the User Preferences tab.
  2. In the Capture section, make the required changes.
    The default free space remaining is:
    • For optical data capture: 10 GB
    • For video capture: 50 GB

You can also select or clear the check  box to enable a warning if video cameras are enabled, but video capture is disabled.

Marker reconstruction radius

In Shogun Live, a new option in the View Filters in the 3D Scene view enables you to display markers based on their physical size, instead of the default (7 mm) size.

This is particularly useful if you have a high density of small markers, for example for facial motion capture, or if you're using the new fingers marker sets.

MCP review via Shogun Live SDK

You can now launch and control MCP review using the Live SDK.

For more information, see the Live SDK sample script included in the API package (by default installed in C:\Program Files\Vicon\ShogunLive1.3\SDK\) and the information in the supplied code.

The sample script (playback.py), enables you to open an MCP for review in Shogun Live by specifying a capture name, as shown in the following example, or just review live data if no name is specified.

python playback.py --name Jack_Fin_2019-10-15_17-19-26

Shogun Post 1.3

For descriptions of the major new features in this release of Shogun Post, see the following topics:

High fidelity finger support

Shogun Post supports the new high fidelity fingers marker sets and works with the Subject Setup panel and offline workflow.

You can change various parameters to get the best results, for example, you can scale the hands if they are too large or add pre-rotations to joints to get a better fit.

For more information, see Vicon Shogun 1.3 Post Tutorial - Finger Solve Adjustments on YouTube.

Retarget support

You can now import your own FBX or USD file and use it for retargeting in Shogun Post. After you've prepared it, adjusted its pose and added constraints, you can export to FBX, USD, or VSR for use in other takes in Post or to use the VSR in real time in Live.

For more information, see:

Retarget with Shogun Post in Getting started with Shogun

and the relevant videos on YouTube:

Vicon Shogun 1.3 Post Tutorial - Retargeting Setup

Vicon Shogun 1.3 Post Tutorial - Retargeting Test

Vicon Shogun 1.3 Post Tutorial - Streaming Retargets into Unreal

   

Enhanced scene visualization

Shogun Post now offers the following features to help you better visualize your scenes.

Volume Visualizer for checking camera coverage

Shogun Post now provides a tool that lets you visualize camera coverage of real or virtual volumes based on the cameras in the scene.

The tool draws voxels for each theoretical ray intersection of cameras in the scene. This means that, within a box encompassing all cameras, every X distance from one corner to the opposite corner a box is drawn if cameras can see that position in space. You can configure how many cameras need to see that position and change other options such as whether or not to visualize camera frustums, define the volume size and the color scheme.

To configure the Volume Visualizer, click Camera Calibration and in the Camera Calibration panel, click the Volume Visualization tab.

For more information, see:

Visualize camera coverage in Getting more from Vicon Shogun

and

Vicon Shogun 1.3 Post Tutorial - Volume Visualizer on YouTube.


Static FBX support for scene visualization

To help you visualize your scene, you can now import FBX files to use as objects in your scene. You can also create Mesh objects, to which you can attach FBX files, and manipulate them within your Shogun scene.

This might be useful when you want to visualize your existing 3D environment within Shogun to enable you to position the characters accurately, or to help with camera placement.

For more information, see the following steps and watch Vicon Shogun 1.3 Post Tutorial - Static FBX Meshes on YouTube.

To import an FBX file as a static object:

  1. Drag the FBX file into the Shogun Post view pane.
  2. When you are prompted, choose Mesh.

To create a static FBX object:

  1. On the Objects menu, point to Create objects, then click Create Object.
  2. On the left of the Create Object dialog box, click Mesh, enter a name for the new object on the right and then click OK.



  3. In the Attributes panel, enter or browse to the FBX file of the required mesh.

     

When you have created or imported the object, you can then move the object to the required position as normal.

Create multiple objects

To make it quicker and easier to create multiple instances of an object (for example, if you want to create a number of cameras to help you to visualize a new capture space), you can now specify the number of objects to create when you create an object.

To create multiple objects:

  1. On the Objects menu, point to Create objects, then click Create Object.
  2. On the left of the Create Object dialog box, click the type of object you want to create (in this example, Camera).
  3. On the right of the dialog box:
    1. Enter a name for the object you're creating.
    2. In the Options select Create Multiple and if necessary, change the value to the required number of objects.
    3. Click OK.

  4. To check that your new objects are displayed, open a Selection panel.
  5. With the Object Manipulator, move the objects to their required positions.

For tips on creating multiple objects and using the Selection panel, see Vicon Shogun 1.3 Post Tutorial - Object Creation and Selection List on YouTube.

Additional export formats

The following additional export formats are now available.

TRC file support

Shogun Post has restored the ability to export skeletal data in TRC format.

To use this feature, with your data loaded in Shogun Post, on the File menu, click Export and from the Save as type list, select the Motion Analysis Trajectory (*.trc) option.

See also trcExportOptions in the Vicon Shogun Scripting Guide.

USD file support

With Shogun Post, you can now import and export skeletal data in USD format. This lets you quickly get animation data onto an IOS device like an iPhone or iPad and to make use of features like the new ARKit technology.

To use this feature for export, with your data loaded in Shogun Post, on the File menu, click Export and from the Save as type list, select the Pixar USD option.

See also usdExportOptions and usdImportOptions in the Vicon Shogun Scripting Guide.

Ability to resample data

In Shogun Post, the new resample command enables you to resample captured data to a different timecode standard and/or rate.

You can convert your motion capture data to a new timecode and/or rate that you specify and export the data saved at the new rate.

You can also specify whether to include unlabeled markers and gaps in the converted data.

For more information see resample in the Vicon Shogun Scripting Guide.

Gap-filling made easier

The following additional features have made filling gaps easier and more automated.

Marker gap list with ranges and auto-selection

You can now conveniently view all the gaps in your scene in the Marker Editing panel, in the Fill Gaps section, by looking at the Gap List. To make it easy to find the longest gaps, click the Length column heading to rearrange the list, with the longest gap at the top.

When you select a gap in the list, it is automatically displayed in the Graph view, so that you can edit the gap quickly and easily.


New intelligent rigid body fill tool

Shogun Post now enables you to automatically fill gaps using a rigid fill operation. This looks at all the markers in your scene and then compares them against the marker you are trying to fill. It then uses a combination of similarly moving markers to fill the gap. Finally, it checks the fill to make sure it looks correct and if not, it chooses another set of markers.

For more information, see:

Auto-fill with intelligent rigid fill in Getting Started with Vicon Shogun, Clean up data

and

Vicon Shogun 1.3 Post Tutorial - Gap List & Auto Rigid Fill on YouTube

In and Out smoothing for filters

The new Smooth In/Out option in the Marker Editing panel offers smoother blending at the start and end of the filtered section of a trajectory curve.

For details, see:

Ensure smooth start and end to filtered trajectories in Getting Started with Vicon Shogun, Clean up data

and

Vicon Shogun 1.3 Post Tutorial - Filter in/out Smoothing on YouTube.

View Filters reorganized in Post

The View Filters for the 3D Scene view have been enhanced and reorganized to make them easier to use.

In the Subjects section, the view options are displayed in a matrix, with columns for Labeling, Solving, Retargeting and Props, enabling you to choose a view configuration that suits your current task.

The default view filter sets are for labeling, solving, and retargeting, but you can add your own filter sets by clicking New Preset.

To rename, copy, remove or restore any filter set to its default value, right-click on a filter set and then click the required option.

Your settings, including any custom presets, are automatically saved, so that you can easily re-use them for different workflows.

New scripting commands

The following new/restored scripting commands are available in Shogun Post:

Other new features

Shogun 1.3 includes the following smaller features:

Shogun Live minor new features

  • Camera zoom: You can zoom a camera's view by using the middle mouse button or mouse wheel.
  • Red border for disconnected cameras: To make it easy to tell when cameras have been disconnected, camera views now display a red border to indicate this.

     

    This is particularly useful for large systems, for example, with 100+ cameras.



  • Grayscale hotkeys: You can cycle through the camera Grayscale Mode setting using a hotkey, which helps to speed up camera setup. You can also use hotkeys to turn the Grayscale view option on and off in the Cameras view.

    To cycle through the Grayscale Mode options for one or more selected cameras, press Ctrl+G. This saves you from having to select the option for the camera(s) on the System tab.



    To enable the Grayscale view option in the Cameras view for all or selected cameras, press G.
    To disable the Grayscale view option, press Shift+G.
  • Zoom in to grayscale markers. In the Cameras view, to zoom in to display any grayscale markers present, in the View Filters, go to the 2D Data options and select Maximize Grayscale.
  • Reboot offline devices. To reboot cameras that are part of the system, but that are currently offline, on the System tab, right-click a device and then click Reboot Non-Contributing Devices.
  • Video camera warning: If Vue or SDI video cameras that are part of the system but that are not turned on for capture, a warning is displayed.

Shogun Post minor new features

  • On the Object menu, a Duplicate option is now available (hotkey is Ctrl-D).
  • While pre-selection (the highlighting of the marker or object that the mouse pointer is currently hovering over) is useful in some circumstances, in others it may be distracting. In the Preferences dialog box (General > Preferences), a new option on the Interface tab enables you to choose whether to show pre-selection in the 3D Scene view.

     

    A related option Show selection pick menu, enables you to choose whether to display the menu that is displayed when you hover the mouse pointer over several markers or objects that are on top of each other. When selected, you can quickly choose from a list of markers or objects, without having to use the Selection filters.



    When cleared, no menu is displayed and you can select only the object that is directly under the mouse pointer.
    See also Vicon Shogun 1.3 Post Tutorial - Selection Toggles on YouTube.
  • Custom folder for saving subjects. To change the default folder to which to save subjects, in the Preferences dialog box, click the Subjects tab, where you can browse or specify the required folder. You can also specify that the current Eclipse session is used by selecting Use active session for subject I/O.



  • Scale missing markers. To scale the displayed size of missing markers, in the Preferences dialog box, click the Interface tab and at the bottom, change the value of the Missing Marker Size Multiplier (the default is 2.50).
  • Hold the Ctrl to use the Manipulator. To avoid accidentally manipulating objects when using the Alt key to select, you can turn on the requirement for the Ctrl key be held down to manipulate objects in the 3D Scene view by selecting this option on the Interface tab of the Preferences dialog box. By default, the option is set to off.



  • Manipulator is now degrees-of-freedom aware. Only the DOF that are active are drawn with the manipulator, this means you can only rotate around the active axis.