Important

To package a project, you must install the Vicon Unreal plugin version 1.4.2 or later.


On this page:



Requirements for packaging a project

Before you begin packaging a project, ensure the following requirements are met:

  • 1 x PC with Vicon software with a subject/object ready to stream
  • 1 x PC with Unreal Engine installed
  • PCs connected via LAN
  • Latest version (1.4.2 or later) of the Vicon LiveLink Unreal Engine plugin installed on the Unreal Engine PC (see Install and set up the LiveLink plugin).
  • Latest Version of Visual Studio 2019 with these modules installed:
    • .Net desktop Development
    • Desktop Development with C++
    • Game Development with C++
  • Unreal Engine Project created and open

Set up the project

Ensure the project is set up and ready to package, with animation data already streaming through Live Link. This requires that:

  • Vicon software is set up and streaming the subject/object.
  • The Vicon Live Link plugin is installed and set up correctly.
  • The correct FBX has been imported for the subject.
  • The animation blueprint has been set up with Live Link, and animation is streaming to the skeleton.
    For Evoke: Stream from Vicon Evoke
    For Shogun: Stream from Vicon Shogun
    For Tracker: Stream from Vicon Tracker

Set up Live Link for packaged source creation

In a packaged .exe, the editor GUI is not available.

Convert to C++

Note

With the current version of the plugin, the project can only be packaged if it is a C++ project.

  1. Click File > New C++ Class.
  2. Follow the pop-up wizard to create a new class. This can be any class with any name.

  3. Close the project.

  4. In the project files folder, right-click on the UProject and select Generate Visual Studio project files.



  5. Launch the project by double-clicking on the UProject.

Package the project

  1. Set the map to be the default map. Navigate to Edit > Project Settings.
  2. In the Project Settings window, navigate to Project > Maps and Modes.
  3. Within Maps and Modes, set the Game Default Map to the level you saved previously.



  4. Navigate to File > Package Project > Windows > Windows64 (note that the plugin supports building for x64 systems only).

  5. Create a new folder with a suitable name to store the built files and click Select Folder.

Ensure DLLs are copied

When the packaging has finished, the Vicon DLLs are copied alongside the EXE location in the output folder structure.

  1. Navigate to the folder created above for the packaged project.
  2. Within the build folder, navigate to the executable location.
  3. Ensure all of the Vicon DLLs are present, together with the EXE.

Run the executable

  1. Navigate to the executable folder:
    D:\Unreal Projects\yourProject\buildFolder\WindowsNoEditor\yourProject\Binaries\Win64
  2. Double-click on the executable to launch the game.
    The Live Link source should now have been created and the animation continues to stream as it did within the editor.

Tip

To close the game, press Alt-F4 or type exit into a cmd line, using `.