Additional Nexus reference PDFs:

Nexus legacy documentation:

Vicon Nexus banner

Vicon Nexus 2.9 is a point release that provides features and enhancements in addition to those that were included in earlier releases of Nexus 2.

Nexus 2.9 new features and functions

Nexus 2.9 provides the following new features and enhancements:

For a description of the other features and enhancements that have been released since Nexus 2.0, see the other Nexus What's New PDFs.

To watch Nexus videos, see the Nexus 2 tutorials playlist and the Nexus 2 How To playlist on YouTube.

Improved CGM2 workflow

Location: Pipeline Tools pane > Data Processing operations

The Conventional Gait Model 2 (CGM2) is now fully integrated into Nexus, so that it is automatically installed with Nexus 2.9.

 

For information on using the CGM2 model with Nexus, see Modeling with CGM2 in the Vicon Nexus Reference Guide.

Quick access to data quality information

You can now quickly obtain feedback on the data quality of all your data captures (including those prior to Nexus 2.9) on the Data Management tab, without having to open each trial to access the information on the Quality tab.

On the default Data Management tab, a new Quality column displays data quality information about each trial.

Note
To display quality information, if your trials:
  • Were captured in versions of Nexus earlier than Nexus 2.9, save the trial in Nexus 2.9 (eg, by running the Save Trial - C3D + VSK pipeline operation).
  • Include multiple subjects, you must select a single subject only.

The information displayed (from left to right) is:

  • Number of unused markers
  • Number of gaps in this trial.
  • Percentage of markers in this trial that are labeled.

If you are using a custom scheme for the Data Management tab, you can either revert to the default layout or, to add a Quality column:

  • Right-click on a column and then click Insert column of type and select Quality.

Overlay normalized trial data in Quick Reports

You can now overlay normalized trial data (eg, gait data) in Quick Reports, so that you can quickly observe model outputs and intra-trial repeatability without having to use Polygon.

A new dropdown menu enables you to select the display mode.

You can select from these options:

  • Single Displays either one context (Left or Right) or both (Left and Right) for a specific cycle, for example: Left = Cycle 1, right = Cycle 1. This option displays data as a normalized gait cycle 0-100.
  • Overlaid  Displays either one context (Left or Right) or both (Left and Right) for all cycles. This option displays data as a normalized gait cycle 0-100.
  • All Displays either one context (Left or Right) or both (Left and Right) for all cycles. This option displays data as frames and is not normalized, in a similar way to the previous All cycles feature in Quick Reports.

Ability to mirror video cameras on screen

Location: View pane > Camera view > View menu

You can now mirror the view displayed for both optical and video cameras.

To select this option, in a Camera view, click the View menu and then select Mirrored.

To enable you to quickly identify when you are looking at a mirrored view, the view title now displays Mirrored when this option is selected.

Labeling template (VST) for Hybrid CAST Visual3D model

Location: Subjects Resources pane > Create a new subject from a Labeling Skeleton button or

C:\Program Files (x86)\Vicon\Nexus2.9\ModelTemplates

If you use a Hybrid CAST Visual3D model with Nexus, you no longer need to generate your own labeling template (VST). A Hybrid CAST Visual3D model is included with Nexus 2.9 so that the marker set is automatically labeled when you use the Auto Initialize Labeling pipeline.

Foot strike counter in Camera view for video cameras

Location: Options dialog box (F7) > Footstrikes option > Properties pane

You can now add a foot strike counter to the Camera view, enabling you to get quick feedback on foot contact when watching a video camera view.

You use the foot strike counter in the same way as in the 3D Perspective view (see Automatically assess foot strikes). 



To display a foot strike counter in the Camera view:

In the Options dialog box (F7), ensure that Footstrikes is selected and in the Properties pane on the right, ensure Show in Video Cameras is selected.

Note
You can't select this option while calibrating the cameras.

To change foot strike counter properties:

  1. With a video camera connected and Nexus in Live mode, in the Systems Resources pane, select the video camera.
  2. In the Camera view right-click and then click Footstrike Monitor Settings.

Improvements to Event Identification mode

The following new options are available in Event Identification mode:

Time bar Zoom option

Location: Options dialog box (F7) > Time Bar option > Properties pane > Event Identification Mode section

A new option enables you to choose whether to zoom into the time bar when in Event Identification mode.


To control zooming into the time bar in Event Identification mode:

  • In the Options dialog box (F7), select Time Bar and in the Properties pane on the right, scroll to Event Identification Mode and select or clear Zoom to Event.
  • When Zoom to Event is enabled, you can specify the Zoom Range (the number of frames) either side of the event that you zoomed to in the time bar. The default is 20 frames.

Load view type when in Event Identification mode

Location: Options dialog box (F7) > Event Identification View Options > Properties pane

To make it easier to identify an event more precisely, Nexus now provides an option for Event Identification mode that enables you to quickly load a specific view type. For example, you may find it helpful to be able to quickly view a graph of a particular marker, etc.

To specify the view type for Event Identification mode:

  1. In the Options dialog box (F7), select Event Identification View Options.
  2. In the Properties pane on the right, change View Type to On and in the User-Specified Event Identification View field, select the required view type.
  3. When you select Event Identification Mode, the view type you selected is automatically displayed.


For information about using Event Identification mode, see Add events to trials in the Vicon Nexus User Guide.

Control of popup notifications

Location: Window menu > Error Message Settings option

A new feature enables you to adjust the length of time that popup notifications are displayed and the maximum number of notifications that are displayed.

To control popup notifications:

  1. On the Window menu, select Error Message Settings.
  2. In the Error Settings dialog box:
    1. Change Popup timeout to the length of time (in seconds) that you want the messages to be displayed, up to a maximum time of 10 seconds.
      Note that if you set Popup timeout to 0, the error message remains unless you either click on the message or the Max Errors to Show is reached, when this error message is automatically removed.
    2. Change Max Errors to Show to the number of error messages that you want to be displayed at any one time, up to a maximum of 10 messages.

      The default popup timeout is 5 seconds and the default number of messages is 5.
      If more errors occur within the Popup timeout period, the oldest error is removed from the top of the stack and newest is displayed at the bottom of the stack.

To open the Log, click on any of the error messages.

New pipeline operation for residual analysis

Location: Pipeline Tools pane > Fill Gaps & Filter Data operations

A new pipeline operation enables you to run a residual analysis to determine the optimum cut-off frequencies to apply for a low pass filter for your devices.

Results are displayed in the Log and saved in the trial History.

Important
This feature is for low pass filtering analysis only, eg, for force plates and plantar pressure plates, and not for high-pass filter devices like EMG.



To run a residual analysis for your devices:

  1. In the Pipeline Tools pane, expand Fill Gaps & Filter Data operations and double-click to add Residual Analysis - Butterworth to your current pipeline.
  2. In the Properties pane, select the first and last frames on which to run the operation.
  3. In the Filter Order field, select whether to apply Fourth Order, double-pass (with zero phase lag) or Second Order, single pass (with phase lag).
  4. Select whether to apply the value to All or Selected devices.
  5. In the Steps field, specify the number of frequencies to evaluate.
    Default =50, minimum = 5 and maximum = 200.
  6. In the Rho Squared field, specify the minimum rho-squared value to accept. This is used to determine the linear region of the residual-frequency curve via a simple linear regression.
    Default = 0.95, minimum = 0 and maximum = 1.
  7. Run the pipeline operation to produce the analysis.
    The results of the analysis for each channel are displayed in the Log.
  8. You can now decide which channel output to use to apply as the cut-off frequency for the Filter Analog Data - Butterworth pipeline operation.
    The filter cut-off is dependent on the type of device to which it is applied, eg, how noisy a force plate is: this may differ for analog vs. digital devices.

You can use the Residual Analysis as part of a batch process.

Results of the Residual Analysis are saved in the trial History.

This example was run on the Vicon Sample Data - 2018, Kory Gait. (Note that as residual analysis was required on the selected force plates only, the Devices field was changed to Selected before the operation was run):

Apply delay compensation as a batch process

Location: Pipeline Tools pane > System operations

The new Set Delay Compensation pipeline operation enables you to save time and effort by applying a delay compensation for your digital devices to multiple trials simultaneously, instead of having to open each trial individually and applying the compensation.



To apply a delay compensation to your devices:

  1. In the Pipeline Tools pane, expand System operations and double-click to add Set Delay Compensation to your current pipeline.
  2. In the Properties pane, in the Devices field, select whether to apply the value to All or Selected devices.
  3. In the Delay Compensation field, specify the required value in seconds.
  4. Run the pipeline operation to apply the value to the specified devices.
    The Delay Compensation value is saved and is displayed on the History tab.

To apply the same delay compensation value to multiple trials, add the Set Delay Compensation operation to a custom pipeline and then use batch processing to run the pipeline on marked trials (see Batch process trials).

Delete all events from one context only

Location: Time bar context menu

or

Location: Pipeline Tools pane > Events & timebar operations > Delete Timebar Events operation

You now have the option to clear all events for one context only (ie, for left, right, general and custom events).

You can do this either using the time bar context menu or as a pipeline operation, which enables you to run this as a batch process.

To delete events using the time bar context menu:

  • On the time bar, right-click and then click the required option.

To delete events using the Delete Timebar Events pipeline operation:

  1. In the Pipeline Tools pane, expand Events & timebar operations and double-click on Delete Timebar Events to add the operation to your current pipeline.
  2. Select the operation that you just added to the current pipeline and in the Properties pane, click Show Advanced and select the appropriate values.


    Note that to delete custom events:
    1. Click the downward arrow next to the Context field and clear the Macro check box:
    2. In the Context field, enter the name of the custom event:
  3. Run the pipeline.

New API functions for digital device data

Two new functions, GetDeviceChannelForFrame and GetDeviceChannelForFrameGlobal, enable you to access digital device data that corresponds to optical measurements.

The new functions are available in the the SDK for Python, and MATLAB.

The new functions address the issue that while the existing function GetDeviceChannelAtFrame provides the analog frame that contains the requested optical measurement (ie, the frame number  in Nexus), for digital devices the analog frame may not align with the optical measurements. The new functions return the analog samples that correspond to the optical frame requested.

Note that these functions are not available in the Datastream.

The following is an example of using GetDeviceChannelForFrame:

import ViconNexus
vicon = ViconNexus.ViconNexus()
# ... stuff to work out what IDs are available...

# demonstrate that the frame counters are different for the system and the forceplate (output results are different)
# demonstrate that frame length is different (different number of samples, 16 vs 10)
vicon.GetDeviceChannelAtFrame(10, 1, 1, 100)
# output ([-0.475459, 1.28333, 0.554047, -0.855607, -3.24367, -2.81851, -1.16626, -0.394893, -2.00863, -3.02354, -2.41265, -0.732007, -0.266873, -0.487017, -0.627091, 0.381795], True, 1000.0)
vicon.GetDeviceChannelForFrame(10, 1, 1, 100)
# output ([-2.00863, -3.02354, -2.41265, -0.732007, -0.266873, -0.487017, -0.627091, 0.381795, 1.51932, 1.49286], True, 1000.0)

# demonstrate that the forceplate has an initial sample offset
# (ForFrame initial sample is AtFrame's 11th sample at frame 1)
vicon.GetDeviceChannelAtFrame(10, 1, 1, 1)
# output ([0.18679, 0.174022, 0.191151, 0.301362, 0.0804058, -0.479919, -1.002, -1.38398, -1.51135, -1.14212, -0.547826, -0.127377, -0.0933952, -0.106104, -0.190911, -0.428488], True, 1000.0)
# compare this to the graphed value, initial sample here is the value at frame 1
vicon.GetDeviceChannelForFrame(10, 1, 1, 1)
# output ([-0.547826, -0.127377, -0.0933952, -0.106104, -0.190911, -0.428488, -0.649677, -0.551753, -0.666456, -0.713149], True, 1000.0

Help on GetDeviceChannelAtFrame:

Help on GetDeviceChannelForFrame:

New SDK command to identify active subjects

A new SDK command, GetSubjectInfo, lets you identify which subjects are active for the current active trial.

The new command is available in the Nexus SDK for both Python and MATLAB.

Ability to run a monitor in a pipeline

Location: Pipeline Tools pane > System operations

To run a monitor as part of a pipeline:

  1. Make sure that you have created the monitor you want to use (see Create a monitor in the Vicon Nexus Reference Guide). Also ensure Nexus is in Offline mode.
  2. In the Pipelines Tools pane, expand System and then double-click Run Monitor to add it to the current pipleline.
  3. Select Run Monitor and in the Properties pane, select the required frames and from the Monitor Configuration list, select the monitor you want to run.
  4. Run the pipeline.

You can run the pipeline on multiple trials via batch processing. 

Improved calibration volume reproducibility

Location: System Preparation Tools pane > Set Volume Origin section > Show Advanced option > Auto Scale option

To achieve maximum positional reproducibility of the Vicon coordinate system, you can create a large custom L-Frame object from markers permanently placed around the edge of the volume. You can then use this L-Frame object for subsequent setting of the system origin.

This provides a high degree of precision of the coordinate system across the camera calibration, which is particularly useful in larger volumes.

To help with this, select the new Auto Scale option when you set the origin, as described below.

This improves the consistency of the volume size, further improving the positional reproducibility.


Note
The following procedure describes how to create a custom L-frame in Nexus. You can instead create an L-frame object in Tracker and export it for use in Nexus, but remember to first copy it from your Tracker CalibrationObjects folder:

C:\Users\Public\Documents\Vicon\Tracker3.x\CalibrationObjects

to your Nexus CalibrationObjects folder:

C:\Users\Public\Documents\Vicon\Nexus 2.x\CalibrationObjects

To perform a camera calibration with rescale:

  1. With Nexus in Live mode, mask and calibrate the cameras (see Mask unwanted reflections and Calibrate Vicon cameras in the Vicon Nexus User Guide).
  2. Using an Active Wand, set the volume origin (see Set the volume origin in the Vicon Nexus User Guide).
  3. Place the markers that you want to use to create the L-Frame subject around the edges of the volume.
    Note that you must use at least four markers that span the whole volume.
  4. In the Capture Tools pane, click Start to capture a short (eg, 5-second) trial.
  5. With Nexus in Offline mode, on the Data Management tab at the bottom of the Nexus window, load the trial that you just captured.
  6. Run the Reconstruct pipeline (see Reconstruct and label movement trials in the Vicon Nexus User Guide).
  7. In the Subject Preparation Tools pane, go to the Create L-Frame Subject section.
  8. In the Create L-Frame field, enter a suitable name (eg, My L-Frame), and click Create.
  9. In the view pane, select the markers that you want to use to create the L-Frame subject.
  10. When you have selected all markers, click Create again.
  11. In the Subjects Resources pane, right-click on the subject and then click Save Subject.
  12. Right-click again on the subject, click Export to L-Frame List and click Yes when prompted.
  13. With Nexus back in Live mode, in the System Preparation Tools pane, in the Set Volume Origin section, ensure Show Advanced is selected.
  14. Click on the L-Frame menu to select the new L-frame and ensure Auto Scale is selected.
    This ensures that the marker distances in the new L-frame are used for volume scaling.
  15. Click Start.
    The system scale is adjusted to provide improved positional reproducibility.