Vicon Nexus banner

This information is for Vicon Nexus 2.7. For up-to-date help, see the latest Nexus documentation.

In addition to the new features described in Vicon Nexus 2.7 new features and functions, the following enhancements were also added:

High-pass filter 

Location: Tools pane > Pipelines tab > Fill Gaps & Filter Data pipeline operations > Filter Analog Data - Butterworth operation

A new option for the Butterworth filter pipeline operation now enables you to remove low-frequency noise from your data.

To use the new high-pass filter option:

  1. On the Pipelines Tools tab, double-click Filter Analog Data - Butterworth to add it to the current pipeline in the usual way.
  2. In the Properties pane, specify the required options and from the Filter Type list, select High Pass.
    When you run the pipeline operation, low-frequency noise is filtered from your data.

Manage sounds configurations

Location: Window menu > Sounds (or F6)

You can now use the configuration management area at the top of the Sounds dialog box to name, to save, delete and if necessary protect the sounds that you have allocated to Nexus events. After you have saved sounds configuration files, you can select them from the menu at the top of the dialog box and can use the Configuration menu to manage them.

The sounds configuration file (*.AudioScheme) is saved into an AudioSchemes folder, in the same location as other Nexus configuration files (see Managing configurations in Vicon Nexus).

Quickly check for camera firmware updates

Location: Help menu > Check for firmware updates option

Nexus 2.7 provides a quick and easy way to check when new firmware is available for your cameras.

To check the latest released firmware version:

  • On the Help menu, click Check for firmware updates.

    The Checking Firmware Version dialog box displays information about the latest released firmware version.

To check the firmware that your system is using:

  • Ensure the system is in Live mode, and in the System Resources pane, right-click Local Vicon System and then click Reprogram Vicon Firmware.
    The firmware version currently used by your system is displayed in the Version column for every connected device.

To download the latest firmware, visit www.vicon.com/downloads/utilities-and-sdk/camera-firmware .

You can then update your firmware using the Reprogram Firmware dialog box.

Visualize Plug-in Gait joint centers

Location: Tools pane > Pipelines tab > Data Processing pipeline operations > Process Static Plug-in Gait Model operation

A new option in the Properties for the Process Static Plug-in Gait Model operation enables you to visualize the joint centers that are calculated by Plug-in Gait.

Protect system configuration files

Location: Various (see Managing configurations in Vicon Nexus).

The Nexus configuration management menus now contain an additional option to enable you to protect configuration files from accidental changes.

To prevent changes to a configuration file:

  1. Ensure the required configuration is selected in the drop-down menu to the left of the configuration management section.
  2. In the relevant configuration management section, click the Configuration menu button.
  3. In the menu, select Mark Read-Only.

Support for Vertex cameras


Nexus 2.7 provides support for Vicon Vertex cameras, which has the added benefit of providing related calibration improvements for other lenses, in particular improved linearization at the edges of lenses.